No Network Xperia X8

  • I have no network on my Sony Ericsson Xperia X8, there is a red x above the signal strength, which is at 0. Every now and then a small E appears above the download/upload arrows and takes the signal bars up, but when I try to make a call, down they go again. Its not the carrier cause my husband is with the same carrier and his phone is on the highest signal strength.



    Like this post to subscribe to the topic.
  • Can you and your husband switch card with each other just to see if this works? If it's a phone related issue it should not make any difference. If it's a SIM card or network related issue you should get the same network access as your husband get's right now.

    Let me know!

    -Markus

  • Hi Markus,

    I swapped sims and now both phones working fine.....dont understand it?? Thanks for the reply. looks like I get stuck with the old phone :-(

  • Sometimes a SIM card will work fine in one phone but not in others. Try contacting your network operator and ask for a new one since the old one's giving you problems. Should not be a problem for them to send you a new one.

    -Markus

  • True? Even if it was working fine in the Sony Ericsson before? I will do that, thanks very much for the advice, much appreciated :-)

  • To be honest, I can't promise this will solve the problem but since your husbands SIM card works in your phone, and that combined with my experience tells me it's by all means worth a try to get a new one.

    Let me know if this helped or not. :)

    -Markus

  • hi hope you can help me. im from the philippines. i upgraded the android in my xperia x8. after succesful update, my fone can't connect my sim to the network. i tried switching sim cards, but stil the same. it can detect the signal, even my network, but when i select it, it says "sim does not allow connection of this network"

  • Have you had your handset previously unlocked to any network? - Aimee.

  • nope. when i insert a simcard from another network, it asks for a unlock code.. the fone came from the network company, like a bundle....

  • help please

  • Hi RC I have the exact same problem.. I ot mine from smart yesterday. I tried another SMart SIM and it works.. but mine has the same prob as yours. it detects SMRT but says no service and It says my SIM does not allow a connection when I try it manually. Have you resolved it?

  • nope. not yet. im stil waiting for their reply.. will be going to smart/sony service center later this. i just tried posting here, maybe i can fix my phone here.. my sim's smart addict

  • You need to replace your SIM with a new compatible one. it's fast just get one from the wireless center. mine works fine now

  • ah. ok.. thanks.. d o i need to pay for the new simcard? im on postpaid

  • yes it's 350 or something like that... but the call center told me I didn't need to pay then when I got there they said I have to.. ugh... I was in a hurry and didn't have time to argue. anyway, try to tell them that it's not your fault and they should replace it free of charge

  • thanks!

  • I have the same problem with my X8 i cant get a signal in my house

  • I think you may consult with network service first

    I am a X8 user too.But I am free from this problem.

  • hi All,

    i guess this might be a problem with X8? as i have the same issue, after i upgrade to v.2.1 (i did it soon i received my phone) i always get "no network" and when i tried to select my network(which is 3) it say "sim does not allow connection of this network", i have to turn the phone off and back on, and it will work "SOMETIMES"..

    and due to that problem, i need to make like 10-15 calls and one go thru.

    I also found it weird that, when i can't call out, i only found the upload arrow blinking but download arrow remine the same ( empty). i've also tried to reformat the phone and re-install the firmware, but issue presist.... is there any thing tht we can do to fix it, or we just need to get a new phone...?? (i have use this one less than one yr....)

  • i wonder why is there no one from SE admin answering this problem, they just gona disregards this thread????

  • Better post in new thread...

  • Hey..I got same problem..But now,i know how to fix it..It's easy..This STEP ONLY FOR X8 Under 11W28!.

    1.Connect your Phone using USB (Debugging Must activate) And Run > msm7227_setool2 >U must get like this:

    "process requires standard 2.x android firmware. Press any key to continue . . .

    Getting ROOT rights. 1743 KB/s (585731 bytes in 0.328s)

    error: protocol fault (no status)

    Waiting ...

    Removing NAND MPU restrictions via SEMC backdoor. Permanent.

    Require ROOT rights.

    192 KB/s (3087 bytes in 0.015s)

    success

    Waiting ...

    Getting ROOT rights. Waiting ...

    Writing patched semcboot.

    Two step process First, we need get access to semcboot area 504 KB/s (8064 bytes in 0.015s) Second, we need to write semcboot ;) 1130 KB/s (596916 bytes in 0.515s)

    successfully wrote 0003ff00 Press any key to continue" *(Dont press any key..Just close it.If not,It will make your phone HardBRICK) . . .

    2.After that..Dont unplug your usb yet just click again to >msm7227_semc>Same step at step 1>your phone will reboot automatically..Just wait..ENJOY WITH YOUR SIGNAL BACK!!.

    I DONT RECOMMENED YOU TO DO THIS..DO WITH YOU OWN RISK!!.Thanks IF I HELPED!!..

  • Hi Mitz Shawn, does that works as well for X8 under 11W44 and above?

    I've got same problem, my phone was previously unlocked to other networks, then I use the airplane mode then got no signal or my x8 could not read my SIM CARD. Thanks for the help...

  • Jun Penalosa:Nope...It's work onLy under 11w28..At above 11W28,dont try this..It cause ur phone brick and HARDBRICK...ok?.THANKS IF I HELPED..

  • Hi Mitz Shawn, does that works as well for X8 under 11W44 and above?

    I've got same problem, my phone was previously unlocked to other networks, then I use the airplane mode then got no signal or my x8 could not read my SIM CARD. Thanks for the help...

  • Okay Thanks Mitz Shawn.

  • okay..U are welcome Dude..:)..do u know how to get dual touch or multi touch on x8?.

  • Yes, you need to have an xgesture file to your system files to get dual touch. By the way, as an update, i went to one of the repair shop here, they said the no network problem on my X8 is because of tampered hwconfig and it needs to rebuild, hopefully my X8 will be okay by tomorrow.

  • Emm..Oh yeah?.so,i hope ur phone will be okay..But,i got same problem too..My Phone was not get any Network..Even I search it..when I unlock Bootloader for 2 times,i get back my Network..XD..